[WNYLUG-Users] Port Forwarding

Joe LaVigne joe at hits-buffalo.com
Tue Mar 20 19:14:46 EDT 2012

Ive never seen a router that provides dhcp that doesnt have static mappings available. Should ne rather straightforward. 
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Monkberry <peter at monkberry.com> wrote:

Easy enough with isc-dhcp-server and a mac address but I don't know about with what he has, even with dd-wrt.

On 03/20/2012 05:49 PM, Joe LaVigne wrote: 

OR, you could set your dhcp server to always give your laptop the same IP address, and not have to worry about it again... 


On 03/20/2012 01:30 PM, josephj at main.nc.us wrote: 

First reply got sent by accident. 

HTML gone.  Thank you. 

I don't like upnp either.  When I tried it a few years ago, it cluttered 
my router with a bunch of "one-time" rules.  As for the rest of your reply 
and the dns example, I didn't quite understand it. 

It would be nice to do, but it's not a very big deal to define one rule 
per possible ip and just see which ip I have today and adjust the port 

I suppose I can write a script that retrieves my IP and then tells me what 
port to use (pretty easy in bash). 


On 03/20/2012 03:16 AM, josephj at main.nc.us wrote: 

Pete: Are you posting to the list in HTML?  Normally, it wouldn't be a 
problem, but, for now, I don't have Thunderbird fully installed where it 
needs to be and my webmail system puts all the HTML from your messages 
into my replies as text and I have to remove them by hand - which is a 
real drag.  I'm not seeing this problem on anybody else's posts. 

How about now? 

I love it when things start working for no apparent reason.  I didn't do 
anything that I'm aware of, but now, my second rule, port 5191 to 5191 
to works. 

I only suggested to test to start diagnosing at a most basic 
level. You can't port forward to this address because it is not 
individual (everyone has it) and it's only internally accessible. You'll 
need to use the IP address of the box itself. 

I had to do a different nmap command (lifted from the man page) to see 

Remaining question (assuming things continue to work): 

How can I configure the router to do 
"open port 5190 for me no matter what my local ip is."  (My ip (in bash 
pattern lingo) will probably be[0123])? 

Not recommended. This could be accomplished with upnp on the router but 
I've never liked the idea of routers creating port forwards all by 
themselves. Without that option, your scenario would be like having a 
public IP assigned to a DNS entry and then the IP changing, thereby 
breaking the DNS entry, but this would all be on the inside. 


shelelia at halo:~$ nmap -A -T4 

Starting Nmap 5.21 ( http://nmap.org ) at 2012-03-20 02:40 EDT 
Nmap scan report for localhost ( 
Host is up (0.00022s latency). 
Not shown: 996 closed ports 
22/tcp   open  ssh             OpenSSH 5.8p1 Debian 7ubuntu1 (protocol 
| ssh-hostkey: 1024 6f:c9:34:81:ed:f3:6d:1a:16:5f:8d:7d:36:95:00:b4 
|_2048 05:2d:5e:21:62:57:38:c1:cc:43:7c:6b:3a:44:08:e0 (RSA) 
631/tcp  open  ipp             CUPS 1.4 
902/tcp  open  ssl/vmware-auth VMware Authentication Daemon 1.10 (Uses 
5190/tcp open  tcpwrapped 
Service Info: OS: Linux 

Service detection performed. Please report any incorrect results at 
http://nmap.org/submit/ . 
Nmap done: 1 IP address (1 host up) scanned in 6.26 seconds 
shelelia at halo:~$ 

      on the .101 box 
      nmap -sP 
      and see if the port is actually open and correct. 

      on the router, make sure you don't have a port range forward setup 
      that your overlapping with a single port forward 
I have a Time Warner Internet connection with a Linksys 
WRT54G wireless 
router.  (I switched it to HTTP and WPA and it works now.) 

I want to get port forwarding to work. 

I have an application that I use on port 5190.  When I hook the 
directly to the modem, the port is open, so there doesn't appear to be 
problem on the ISP end. 

I went into the router and selected Applications and Gaming.  I set up 
rule: start 5190, end 5190, Both protocols, to and 
rule for 5191 to 5191, both, to 

5190 times out and 5191 gets refused. (tested using 

ifconfig says wlan0 is at 
I think it's at 101 instead of 100 because I had the notebook connected 
Ethernet cable just before I did this. 

1) How do I fix this? 

2) I would like the port to be open at whatever local ip address gets 
assigned to my notebook.  I told the router to allow 4 connections, so 
I have to set up one rule for each ...100 to ...103?  The router didn't 
seem to want to do that for 100 and 101.  It complained about port 
overlapping.  I don't want to have to look at the ip that gets assigned 
my notebook and then change what port I'm using because of that. 

Is there a way to do this that doesn't involve too much rocket science? 

3) Given that I do not have any vms running at the moment, why do 
and vmnet8 show up at all?  Is that normal? 

I originally ran my Windows 7 vm using vmware player ad then converted 
to VirtualBox.  (Again, it's not running now.) 



shelelia at halo:~/pq$ ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:23:18:08:37:93 
            inet6 addr: fe80::223:18ff:fe08:3793/64 Scope:Link 
            UP BROADCAST MULTICAST  MTU:1500  Metric:1 
            RX packets:25833 errors:0 dropped:0 overruns:0 frame:0 
            TX packets:17296 errors:0 dropped:0 overruns:0 carrier:0 
            collisions:0 txqueuelen:1000 
            RX bytes:6673182 (6.6 MB)  TX bytes:1998361 (1.9 MB) 
            Interrupt:20 Memory:d4600000-d4620000 

lo        Link encap:Local Loopback 
            inet addr:  Mask: 
            inet6 addr: ::1/128 Scope:Host 
            UP LOOPBACK RUNNING  MTU:16436  Metric:1 
            RX packets:1536 errors:0 dropped:0 overruns:0 frame:0 
            TX packets:1536 errors:0 dropped:0 overruns:0 carrier:0 
            collisions:0 txqueuelen:0 
            RX bytes:123684 (123.6 KB)  TX bytes:123684 (123.6 KB) 

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01 
            inet addr:  Bcast: 
            inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link 
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
            TX packets:1022 errors:0 dropped:0 overruns:0 carrier:0 
            collisions:0 txqueuelen:1000 
            RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B) 

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08 
            inet addr:  Bcast: 
            inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link 
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
            TX packets:1021 errors:0 dropped:0 overruns:0 carrier:0 
            collisions:0 txqueuelen:1000 
            RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B) 

wlan0     Link encap:Ethernet  HWaddr 00:23:15:92:c2:14 
            inet addr:  Bcast: 
            inet6 addr: fe80::223:15ff:fe92:c214/64 Scope:Link 
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
            RX packets:11229 errors:0 dropped:0 overruns:0 frame:0 
            TX packets:10149 errors:0 dropped:0 overruns:0 carrier:0 
            collisions:0 txqueuelen:1000 
            RX bytes:9011967 (9.0 MB)  TX bytes:1523202 (1.5 MB) 

shelelia at halo:~/pq$ 


Users mailing list 
Users at wnylug.org 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://wnylug.org/pipermail/users_wnylug.org/attachments/20120320/21322d60/attachment-0001.html>

More information about the Users mailing list