[WNYLUG-Users] bzip2 problems (Solved)

Robert Dege livemotion at gmail.com
Mon Mar 5 10:33:57 EST 2012

Thank you for the responses.  The problem was hardware related, between the
RAM and the Motherboard.  Technically, all I did was move the RAM chips
from DIMM slots 3 & 4 to DIMM slots 1 & 2.  After that, my mysql db imports
worked without issue, as well as my bzip2 integrity tests.  I'm not sure
why MemTest wasn't able to reproduce the problem, but I'm just happy that I
was able to restore stability =)


On Sat, Mar 3, 2012 at 6:58 AM, Tyler Poland <tyler.poland at gmail.com> wrote:

> It sounds like you are dealing with two problems. If the backup was
> corrupted this  shouldn't cause the database to crash. Instead, I suspect
> you had a corrupt innodb file which caused the original crash and when the
> restore tried to drop and recreate the corrupted table the server crashed
> again.  Sometimes the table can be repaired but the typical case is that
> all of the innodb tablespace and log files have to be reinitialized
> (physical file removal and then backup restore). The file corruption can
> usually be traced back to a disk or file system issue (we used to see these
> a lot with reiserfs).
> On another note that doesn't help directly with bzip2, you may want to do
> performance comparisons between that and gzip for mysqldump. We've found
> that the space savings don't outweigh the time savings for extraction and
> compression.
> Tyler
> sent from my Droid Bionic
> On Mar 3, 2012 6:30 AM, <josephj at main.nc.us> wrote:
>> Just some random thoughts.  I don't expect you to answer any of these.
>> Just see if they give you any ideas.
>> Can you bzip2/unzip some other comparable file on the same system to see
>> if it fails or doesn't checksum?
>> Is it physical medium related?  Does the same thing occur for data stored
>> on another drive (but still connected to the same computer)?
>> Is there any temperature increase or system overload?  Is swap utilisation
>> unusual?
>> Can you checksum and/or reinstall bzip2 itself?  Is its revision level the
>> same as on the systems which work?
>> Obviously bzip2 is separate from mysql, so do you have them piped
>> together?  If so, can you use a temporary file and do things separately?
>> Maybe it has something to do with them both running at the same time.
>> Do you have any kind of hardware stress test you can run?  If something is
>> lagging a bit or getting a little out of sync, I don't think a memory test
>> would catch that.  Something with a bunch of simultaneous threads might.
>> That's the sort of thing database servers do.
>> Are the modification times on all the relevant config files what you
>> expect them to be?
>> HTH
>> Joe
>> > I need some help debugging a HW/SW problem.  I'm fairly certain that
>> this
>> > is a hardware related issue, but I'm having a difficult time finding the
>> > issue.
>> >
>> > The problem started when a mysql database crashed.  I do nightly backups
>> > so
>> > I grabbed a dump file and tried to restore, but it failed halfway
>> through.
>> > crashing the mysql service in the process.  After having multiple dump
>> > files fail to restore, I started to create a new test environment when I
>> > discovered that bzip2 was acting weird.  Files that were tar.bz2 on
>> > different machines were failing during decompression.  However, I tested
>> > the same archive on 3 different machines and verified that the archive
>> was
>> > good.
>> >
>> > This led me to believe that there is a hardware problem.  I ran memtest
>> > for
>> > about 6 hours, with no errors.  An fsck on both hard drives showed no
>> > issues.  I did a dd if=/dev/sd{a,b} of=/dev/zero, it had no read/write
>> > issues.
>> >
>> > Any advice is appreciated.  I'm running mythbuntu 11.10, on an Athlon64
>> > w/2GB RAM
>> >
>> > -Rob
>> > _______________________________________________
>> > Users mailing list
>> > Users at wnylug.org
>> > http://wnylug.org/mailman/listinfo/users_wnylug.org
>> >
>> _______________________________________________
>> Users mailing list
>> Users at wnylug.org
>> http://wnylug.org/mailman/listinfo/users_wnylug.org
> _______________________________________________
> Users mailing list
> Users at wnylug.org
> http://wnylug.org/mailman/listinfo/users_wnylug.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://wnylug.org/pipermail/users_wnylug.org/attachments/20120305/1f55b7fa/attachment.html>

More information about the Users mailing list