[WNYLUG-Users] bzip2 problems

josephj at main.nc.us josephj at main.nc.us
Sat Mar 3 06:30:51 EST 2012


Just some random thoughts.  I don't expect you to answer any of these. 
Just see if they give you any ideas.

Can you bzip2/unzip some other comparable file on the same system to see
if it fails or doesn't checksum?

Is it physical medium related?  Does the same thing occur for data stored
on another drive (but still connected to the same computer)?

Is there any temperature increase or system overload?  Is swap utilisation
unusual?

Can you checksum and/or reinstall bzip2 itself?  Is its revision level the
same as on the systems which work?

Obviously bzip2 is separate from mysql, so do you have them piped
together?  If so, can you use a temporary file and do things separately? 
Maybe it has something to do with them both running at the same time.

Do you have any kind of hardware stress test you can run?  If something is
lagging a bit or getting a little out of sync, I don't think a memory test
would catch that.  Something with a bunch of simultaneous threads might. 
That's the sort of thing database servers do.

Are the modification times on all the relevant config files what you
expect them to be?

HTH

Joe

> I need some help debugging a HW/SW problem.  I'm fairly certain that this
> is a hardware related issue, but I'm having a difficult time finding the
> issue.
>
> The problem started when a mysql database crashed.  I do nightly backups
> so
> I grabbed a dump file and tried to restore, but it failed halfway through.
> crashing the mysql service in the process.  After having multiple dump
> files fail to restore, I started to create a new test environment when I
> discovered that bzip2 was acting weird.  Files that were tar.bz2 on
> different machines were failing during decompression.  However, I tested
> the same archive on 3 different machines and verified that the archive was
> good.
>
> This led me to believe that there is a hardware problem.  I ran memtest
> for
> about 6 hours, with no errors.  An fsck on both hard drives showed no
> issues.  I did a dd if=/dev/sd{a,b} of=/dev/zero, it had no read/write
> issues.
>
> Any advice is appreciated.  I'm running mythbuntu 11.10, on an Athlon64
> w/2GB RAM
>
> -Rob
> _______________________________________________
> Users mailing list
> Users at wnylug.org
> http://wnylug.org/mailman/listinfo/users_wnylug.org
>





More information about the Users mailing list