[WNYLUG-Users] wtf java

David J. Andruczyk djandruczyk at yahoo.com
Thu Feb 18 12:05:32 EST 2010


The problem is probably with their java application..
It probably is set to limit logins to one per IP.  Since your client is behind a NAT firewall, everyone shares that external IP),  that may be the cause of the issue.

>From your description the issue doesn't appear to be on your end,  but with their JAVA application.


 -- David J. Andruczyk




________________________________
From: Cyber Source <peter at cybersource.us>
To: Western New York Linux Users Group Users Mailing List <users at wnylug.org>
Sent: Thu, February 18, 2010 9:30:32 AM
Subject: [WNYLUG-Users] wtf java

Have I ever mentioned that I *ucking HATE java!!!!!
Could anything be more complicated, piece mealed and convoluted???!!!

I've spent the past 2 days trying to figure out what the problem is
with connecting to a clients vendors web site that requires
authentication to their web site via a java popup login. After many
many tries of different things like using icedtea vs actual java for
the plugin, different versions of firefox, even trying IE, I get the
same result. The java window will ONLY pop up for one user (not
speaking simultaneously). If I connect once logged in with user
"peter", then it will NOT work if logged into the network as anyone
else, no matter what the changes above. And then it will ONLY work
logged in as "peter". However, if I'm NOT on their network, I can log
in fine from anywhere else no matter what the user I'm logged into the
pc with.

So this leads me to think it must be something on their network. This
is in an LTSP environment so essentially all users have the same
internal IP. 

Is there some "system wide" setting for java that needs to be set other
than putting the plugin for java in where firefox will read it, of
course?
I have a devil-linux box setup as a router that has worked flawlessly.
On that router I can run iptraf and indeed see the connection to their
site on port 50000. Could something be stuck/stale on the firewall
causing this not to work because again, essentially, all users are
using the same IP internally and then when the java applet tries to
run, it can't build what it needs because the user has changed? i.e.
when using the gcjwebplugin, I could see it create 2 symlinks in
~/.gcjwebplugin when connecting under user peter's login. It would
create the symlinks under other users logins but it would bitch about
not being able to build things and the applet would die (running
firefox from command line and seeing output).

Right now my suspicions are with the firewall but with the LTSP
environment, I'm not sure. If you haven't clicked off this message by
now, any ideas anyone?
TIA


-- 
Cyber Source 
115 Richfield Road 
Williamsville, New York 14221 
716-553-8525 


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://wnylug.org/pipermail/users_wnylug.org/attachments/20100218/c24f5ea1/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: logo.jpg
Type: image/jpeg
Size: 4003 bytes
Desc: not available
URL: <http://wnylug.org/pipermail/users_wnylug.org/attachments/20100218/c24f5ea1/attachment.jpg>


More information about the Users mailing list